Subject: [Fictionary] NEW ROUND: Limberham

From: Elizabeth Heffner <[email-masked]>
Date: Tue, 16 Feb 2021 14:38:37 -0500

Thank you for your feedback on the word selection.

The word for this round is LIMBERHAM.

Please submit your definition by the end of Tuesday 23rd February 2021.
:)

May the odds be in your favor!

Cheers,
Liz

---

From: E Cohen <[email-masked]>
Date: Tue, 16 Feb 2021 22:25:22 -0500

> The word for this round is LIMBERHAM.
Parnelled pork.

-- Eric   |   [email-masked]