Subject: [Fictionary] New Word: Ramfeezled

From: Nicolas Ward <[email-masked]>
Date: Mon, 24 Feb 2025 10:40:47 -0800

Send your definitions for ramfeezled by Wednesday 3/5

--Nick

---

From: Nicolas Ward <[email-masked]>
Date: Tue, 4 Mar 2025 16:15:16 -0800

Please get your ramfeezled definitions in by tomorrow! I currently have defs from Jim, E, Pierre, Hutch, J-J, and Joshua... and the dictionary.

--Nick