Subject: [Fictionary] I was left out

From: "[email-masked]" <[email-masked]>
Date: Sat, 8 Oct 2022 17:21:30 GMT

MY def of a ganstger's girlfriend was left out, even though I was not home to vote.  :LInda

---

From: Nicolas Ward <[email-masked]>
Date: Sat, 8 Oct 2022 11:36:50 -0700

Sorry about that Linda! I don't seem to have a message from you for last
round? Although if it went to spam it would be gone by now. :o(

--Nick