Subject: Stirk definitions

From: Mark Jason Dominus <[email-masked]>
Date: Fri, 06 May 2005 03:39:24 -0400

I cannot find anything wrong with the mailing list.  Attached is an
excerpt of my mail log from that time.  Message 704727 is the incoming
message from David Randal with the "stirk" definitions.  Message
705012 is the reflected version that went out to the subscribers.
Delivery started at 10:56:11 and fifteen seconds later it had been
successfully delivered to everyone.

In particular, the remote system that is responsible for receiving
Pierre Abbat's mail acknowledged receipt of the message, and accepted
responsibility for delivering it, when it said

            250 Ok: queued as 4351ACBBAD

The next step Pierre should follow, should he wish to pursue this
further, is to take the date and time and the receipt number
("4351ACBBAD") to the person responsible for administering his own
mail system, and ask them what happened to the message after that.
Similar magic numbers are listed below for almost everyone.

The relevant excerpts of the log follow below, first in a digested
form, and then in the raw form.

704727 (2005/04/12 10:56:10) [email-masked]            2257 b -
  301318 (2005/04/12 10:56:10) l [email-masked]                S 1.1098s
            ezmlm-send: info: qp 17319
            did 0+0+3

705012 (2005/04/12 10:56:11) [email-masked]  2078 b -
  301319 (2005/04/12 10:56:11) r [email-masked]                  S 3.8387s
            63.251.171.165 accepted message.
            Remote host said: 250 OK id=1DLMim-0004mH-Dj
  301320 (2005/04/12 10:56:11) r [email-masked]                  S 2.9719s
            209.2.32.36 accepted message.
            Remote host said: 250 Ok: queued as C6FBB1F522
  301321 (2005/04/12 10:56:11) r [email-masked]                 S 1.9296s
            130.58.64.60 accepted message.
            Remote host said: 250 Ok: queued as 766CFEF8CF
  301322 (2005/04/12 10:56:11) r [email-masked]                     S 1.9026s
            66.93.172.9 accepted message.
            Remote host said: 250 Ok: queued as 40E8754A4
  301323 (2005/04/12 10:56:11) r [email-masked]                S 3.8468s
            64.81.85.145 accepted message.
            Remote host said: 250 ok 1113317433 qp 12668
  301324 (2005/04/12 10:56:11) r [email-masked]                S 4.7886s
            216.189.113.165 accepted message.
            Remote host said: 250 Ok: queued as 4351ACBBAD
  301325 (2005/04/12 10:56:11) l [email-masked]            S 0.7782s
            did 1+0+0
  301326 (2005/04/12 10:56:11) r [email-masked]                      S 1.9956s
            66.93.172.9 accepted message.
            Remote host said: 250 Ok: queued as 7BE925503
  301327 (2005/04/12 10:56:12) r [email-masked]                      S 2.1890s
            209.68.2.189 accepted message.
            Remote host said: 250 ok 1113317433 qp 44783
  301328 (2005/04/12 10:56:12) r [email-masked]                S 4.1350s
            66.114.77.28 accepted message.
            Remote host said: 250 2.0.0 j3CEpmHt006659 Message accepted for ...
  301329 (2005/04/12 10:56:12) r [email-masked]             S 8.2153s
            216.148.222.35 accepted message.
            Remote host said: 250 Ok: queued as E2C5E3D00BD
  301330 (2005/04/12 10:56:12) r [email-masked]                     S 9.0655s
            64.12.137.89 accepted message.
            Remote host said: 250 OK
  301331 (2005/04/12 10:56:12) r [email-masked]                       S 5.0119s
            69.25.201.132 accepted message.
            Remote host said: 250 Ok: queued as EEAC44D8013
  301332 (2005/04/12 10:56:12) r [email-masked]                       S 3.1098s
            209.68.1.13 accepted message.
            Remote host said: 250 ok 1113317434 qp 21077
  301333 (2005/04/12 10:56:12) r [email-masked]                      S 4.1384s
            205.188.159.57 accepted message.
            Remote host said: 250 OK
  301334 (2005/04/12 10:56:12) r [email-masked]            S 3.1222s
            168.215.132.220 accepted message.
            Remote host said: 250 M2005041210503109398 Message accepted for ...
  301335 (2005/04/12 10:56:12) r [email-masked]                   S 8.0366s
            209.198.87.161 accepted message.
            Remote host said: 250 2.0.0 j3CEoWX8013008 Message accepted for ...
  301336 (2005/04/12 10:56:12) r [email-masked]                    S 6.1118s
            128.148.128.170 accepted message.
            Remote host said: 250 2.0.0 j3CEoVHl010559 Message accepted for ...
  301337 (2005/04/12 10:56:13) r [email-masked]                  S 8.0654s
            130.94.234.58 accepted message.
            Remote host said: 250 ok 1113317440 qp 14835 by moonmilk.com
  301338 (2005/04/12 10:56:13) r [email-masked]            S 8.0792s
            209.86.93.238 accepted message.
            Remote host said: 250 1dlmIT2ml3NZFmR0 Message accepted for deli...
  301339 (2005/04/12 10:56:13) r [email-masked]                      S 10.972s
            64.136.28.83 accepted message.
            Remote host said: 250 OK id AABBFZ2B8ANB22HJ
  301340 (2005/04/12 10:56:13) r [email-masked]               S 6.7944s
            192.108.102.204 accepted message.
            Remote host said: 250 OK
  301341 (2005/04/12 10:56:14) r [email-masked]              S 7.9924s
            64.136.28.83 accepted message.
            Remote host said: 250 OK id AABBFZ2B8AVL4YS2
  301342 (2005/04/12 10:56:14) r [email-masked]         S 5.8901s
            198.212.10.95 accepted message.
            Remote host said: 250 Mail accepted
  301343 (2005/04/12 10:56:15) r [email-masked]                S 6.0330s
            69.17.117.60 accepted message.
            Remote host said: 250 ok 1113317440 qp 9113 by mail17.sea5.speak...
  301344 (2005/04/12 10:56:15) r [email-masked]                  S 6.0210s
            64.74.173.111 accepted message.
            Remote host said: 250 Accepted message qp 18453 bytes 2215
  301345 (2005/04/12 10:56:15) r [email-masked]                S 11.064s
            152.2.1.94 accepted message.
            Remote host said: 250 2.0.0 j3CEoi39021513 Message accepted for ...

2005-04-12 10:56:10.513373500 new msg 704727
2005-04-12 10:56:10.513999500 info msg 704727: bytes 2257 from <[email-masked]> qp 17314 uid 1001
2005-04-12 10:56:10.520866500 starting delivery 301318: msg 704727 to local [email-masked]
2005-04-12 10:56:11.717266500 new msg 705012
2005-04-12 10:56:11.718860500 info msg 705012: bytes 2078 from <[email-masked]@[]> qp 17319 uid 1000
2005-04-12 10:56:11.961741500 starting delivery 301319: msg 705012 to remote [email-masked]
2005-04-12 10:56:11.961779500 starting delivery 301320: msg 705012 to remote [email-masked]
2005-04-12 10:56:11.961801500 starting delivery 301321: msg 705012 to remote [email-masked]
2005-04-12 10:56:11.970254500 starting delivery 301322: msg 705012 to remote [email-masked]
2005-04-12 10:56:11.979011500 starting delivery 301323: msg 705012 to remote [email-masked]
2005-04-12 10:56:11.981374500 starting delivery 301324: msg 705012 to remote [email-masked]
2005-04-12 10:56:11.992857500 delivery 301318: success: ezmlm-send:_info:_qp_17319/did_0+0+3/
2005-04-12 10:56:11.994639500 end msg 704727
2005-04-12 10:56:11.998427500 starting delivery 301325: msg 705012 to local [email-masked]
2005-04-12 10:56:11.998465500 starting delivery 301326: msg 705012 to remote [email-masked]
2005-04-12 10:56:12.013138500 starting delivery 301327: msg 705012 to remote [email-masked]
2005-04-12 10:56:12.043118500 starting delivery 301328: msg 705012 to remote [email-masked]
2005-04-12 10:56:12.046121500 delivery 301325: success: did_1+0+0/
2005-04-12 10:56:12.053408500 starting delivery 301329: msg 705012 to remote [email-masked]
2005-04-12 10:56:12.061153500 starting delivery 301330: msg 705012 to remote [email-masked]
2005-04-12 10:56:12.076670500 starting delivery 301331: msg 705012 to remote [email-masked]
2005-04-12 10:56:12.083362500 starting delivery 301332: msg 705012 to remote [email-masked]
2005-04-12 10:56:12.099676500 starting delivery 301333: msg 705012 to remote [email-masked]
2005-04-12 10:56:12.102843500 starting delivery 301334: msg 705012 to remote [email-masked]
2005-04-12 10:56:12.152750500 starting delivery 301335: msg 705012 to remote [email-masked]
2005-04-12 10:56:12.161394500 starting delivery 301336: msg 705012 to remote [email-masked]
2005-04-12 10:56:13.452605500 starting delivery 301337: msg 705012 to remote [email-masked]
2005-04-12 10:56:13.552084500 delivery 301322: success: 66.93.172.9_accepted_message./Remote_host_said:_250_Ok:_queued_as_40E8754A4/
2005-04-12 10:56:13.552135500 starting delivery 301338: msg 705012 to remote [email-masked]
2005-04-12 10:56:13.659767500 delivery 301321: success: 130.58.64.60_accepted_message./Remote_host_said:_250_Ok:_queued_as_766CFEF8CF/
2005-04-12 10:56:13.659812500 starting delivery 301339: msg 705012 to remote [email-masked]
2005-04-12 10:56:13.979887500 delivery 301326: success: 66.93.172.9_accepted_message./Remote_host_said:_250_Ok:_queued_as_7BE925503/
2005-04-12 10:56:13.979932500 starting delivery 301340: msg 705012 to remote [email-masked]
2005-04-12 10:56:14.825296500 delivery 301327: success: 209.68.2.189_accepted_message./Remote_host_said:_250_ok_1113317433_qp_44783/
2005-04-12 10:56:14.825342500 starting delivery 301341: msg 705012 to remote [email-masked]
2005-04-12 10:56:14.841115500 delivery 301320: success: 209.2.32.36_accepted_message./Remote_host_said:_250_Ok:_queued_as_C6FBB1F522/
2005-04-12 10:56:14.841162500 starting delivery 301342: msg 705012 to remote [email-masked]
2005-04-12 10:56:15.269319500 delivery 301319: success: 63.251.171.165_accepted_message./Remote_host_said:_250_OK_id=1DLMim-0004mH-Dj/
2005-04-12 10:56:15.269365500 starting delivery 301343: msg 705012 to remote [email-masked]
2005-04-12 10:56:15.321064500 delivery 301323: success: 64.81.85.145_accepted_message./Remote_host_said:_250_ok_1113317433_qp_12668/
2005-04-12 10:56:15.321110500 starting delivery 301344: msg 705012 to remote [email-masked]
2005-04-12 10:56:15.555209500 delivery 301332: success: 209.68.1.13_accepted_message./Remote_host_said:_250_ok_1113317434_qp_21077/
2005-04-12 10:56:15.555254500 starting delivery 301345: msg 705012 to remote [email-masked]
2005-04-12 10:56:15.627775500 delivery 301334: success: 168.215.132.220_accepted_message./Remote_host_said:_250_M2005041210503109398_Message_accepted_for_delivery/
2005-04-12 10:56:16.073750500 delivery 301324: success: 216.189.113.165_accepted_message./Remote_host_said:_250_Ok:_queued_as_4351ACBBAD/
2005-04-12 10:56:16.623339500 delivery 301328: success: 66.114.77.28_accepted_message./Remote_host_said:_250_2.0.0_j3CEpmHt006659_Message_accepted_for_delivery/
2005-04-12 10:56:16.694497500 delivery 301333: success: 205.188.159.57_accepted_message./Remote_host_said:_250_OK/
2005-04-12 10:56:17.127846500 delivery 301331: success: 69.25.201.132_accepted_message./Remote_host_said:_250_Ok:_queued_as_EEAC44D8013/
2005-04-12 10:56:18.619686500 delivery 301346: deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)/
2005-04-12 10:56:18.641957500 delivery 301336: success: 128.148.128.170_accepted_message./Remote_host_said:_250_2.0.0_j3CEoVHl010559_Message_accepted_for_delivery/
2005-04-12 10:56:20.097246500 delivery 301340: success: 192.108.102.204_accepted_message./Remote_host_said:_250_OK/
2005-04-12 10:56:20.310040500 delivery 301335: success: 209.198.87.161_accepted_message./Remote_host_said:_250_2.0.0_j3CEoWX8013008_Message_accepted_for_delivery/
2005-04-12 10:56:20.369358500 delivery 301342: success: 198.212.10.95_accepted_message./Remote_host_said:_250_Mail_accepted/
2005-04-12 10:56:20.978376500 delivery 301329: success: 216.148.222.35_accepted_message./Remote_host_said:_250_Ok:_queued_as_E2C5E3D00BD/
2005-04-12 10:56:21.342854500 delivery 301330: success: 64.12.137.89_accepted_message./Remote_host_said:_250_OK/
2005-04-12 10:56:21.411521500 delivery 301343: success: 69.17.117.60_accepted_message./Remote_host_said:_250_ok_1113317440_qp_9113_by_mail17.sea5.speakeasy.net/
2005-04-12 10:56:21.411563500 delivery 301344: success: 64.74.173.111_accepted_message./Remote_host_said:_250_Accepted_message_qp_18453_bytes_2215/
2005-04-12 10:56:21.733614500 delivery 301337: success: 130.94.234.58_accepted_message./Remote_host_said:_250_ok_1113317440_qp_14835_by_moonmilk.com/
2005-04-12 10:56:21.892599500 delivery 301338: success: 209.86.93.238_accepted_message./Remote_host_said:_250_1dlmIT2ml3NZFmR0_Message_accepted_for_delivery/
2005-04-12 10:56:22.383376500 delivery 301347: deferral: CNAME_lookup_failed_temporarily._(#4.4.3)/
2005-04-12 10:56:22.792906500 delivery 301341: success: 64.136.28.83_accepted_message./Remote_host_said:_250_OK_id_AABBFZ2B8AVL4YS2/
2005-04-12 10:56:24.340530500 delivery 301348: deferral: 211.20.188.150_does_not_like_recipient./Remote_host_said:_440_Error:_Wrong_recipients/Giving_up_on_211.20.188.150./
2005-04-12 10:56:24.541064500 delivery 301339: success: 64.136.28.83_accepted_message./Remote_host_said:_250_OK_id_AABBFZ2B8ANB22HJ/
2005-04-12 10:56:26.831920500 delivery 301345: success: 152.2.1.94_accepted_message./Remote_host_said:_250_2.0.0_j3CEoi39021513_Message_accepted_for_delivery/
2005-04-12 10:56:26.834266500 end msg 705012

---

From: Pierre Abbat <[email-masked]>
Date: Fri, 6 May 2005 08:04:27 -0400

> Similar magic numbers are listed below for almost everyone.

I run my mail system, and I don't keep logs that long, so I have no way of 
finding out what happened. As I use Maildir throughout, it could not have 
gotten lost because of locking, so the most likely cause is that it was 
misfiled as spam by my procmail script. This could have been caused by 
trouble contacting the Razor server.

phma
-- 
Maintenant, j'ai besoin d'une loupe pour trouver mes lunettes!
	-Les Perles de la médecine

---

From: Pierre Abbat <[email-masked]>
Date: Sat, 7 May 2005 05:11:24 -0400

I got the missing messages with the fictionary-get command and found out why 
my procmail script discarded them: they are written in HTML and are not 
multipart. Messages like that are almost all spam; the only exception I've 
had in the past has been messages from a certain dating site.

I accept multipart text/plain and text/html messages but set my mail client to 
show only the text/plain part for security reasons. When I get a mail in 
text/html only, it shows the HTML code, which is messy, but I'd rather see 
the code than run the risk of running a virus embedded in it. I run Linux, 
which doesn't get viruses, but someone might write a Java virus that does 
affect Linux and send it via email.

phma
-- 
Now I need a magnifier to find my eyeglasses!
	-Les Perles de la médecine