Subject: [Fictionary] first word: BAREN

From: Pierre Abbat <[email-masked]>
Date: Fri, 22 Sep 2023 04:23:02 -0400

This is one of the oldest words on my list; I've had it for fifteen years or 
more. Do any of you know it?

Pierre
-- 
loi mintu se ckaji danlu cu jmaji

---

From: Fran Poodry <[email-masked]>
Date: Fri, 22 Sep 2023 08:14:50 -0700

I don't know baren, and I also don't think I saw the omnium results. Can
you forward the omnium results, please?
Thank you!
Fran

-- 
*Fran Poodry (she/her)*
*Oregon, USA*

*“Children must be taught how to think, not what to think.” ― Margaret Mead
<http://www.goodreads.com/author/show/61107.Margaret_Mead>*